Bugs Thread

Home Forums Wayward Bugs Thread

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #4826

    Since there will be lots of bugs reported in the forums, I thought it might be useful to have a bugs thread for everyone.


    1.9 Bugs spotted:
    Audio (only sounds) stops for no reason occasionally. Exiting the game and coming back fixes this for some time.
    Some items don’t decrease in durability in the quick slots (stone knife, hand drill, etc.) while others work just fine.
    When blood is carved off a tile, the message “There is nothing to carve here!” still pops up.


    I haven’t been able to reproduce this one:

    “Some items don’t decrease in durability in the quick slots (stone knife, hand drill, etc.) while others work just fine.”


    I’m on a new game now and I can’t reproduce it either. Maybe I wasn’t paying attention, or it might have been a temporary problem. Found something new though…when the player eats snow off the ground, there are no ill effects, but when you use a glass bottle or a waterskin to pick up snow, the unpurified water often gives poison or health loss. Not sure if this was intentional, just wanted to put it out there.


    Hello, new to the forums. I am using Firefox 32.0 (This happened in 31.0 as well, funny enough I was checking which version I had when it auto-updated with the “about” window coming up, but the error still occurred).

    I’ve been enjoying Wayward quite a bit, unfortunately I got this error on trying to start the game after I had saved manually and quit:

    TypeError: player.calculateEquipmentStats is not a function

    To elaborate, in this particular file I had played for some several hours dying several times, getting several recipes. I had the container bug where a backpack I placed items in would not let me take them out.

    I died and played a few more times, got the bug again with a small bag, and afterwards I decided to save manually then exit the game hoping it would clear the bug.

    What happened was I was greeted upon bringing up the page with the title as normal, then when I pressed “Continue Game” , nothing happened, I waited, then pressed the button again, nothing. I clicked off the main menu box and saw that the loading clock was running on and on, and a few boxes were up that I did have up before, being the equipment, inventory and crafting boxes, but nothing else.

    When I used the web console as recommended to see the error, oddly enough the title screen went away, the game was still frozen, but I saw the aforementioned windows, and objects that were placed in the world and my character, all up against a black void.

    EDIT: I tried to delete my saved game data on the chance it would do… something. Sadly I still get the same error, except nothing appears when the web console is brought up. Ah well.

    • This reply was modified 9 years, 7 months ago by Instinct8clue. Reason: Attempted fix

    1.9.2 bug…
    Treasure maps not working. I’ve gotten an unreal number of treasure maps with the update and they all work enough to lead me to the spot but no treasure appears. There’s also no message to face the spot where the treasure should be. I’m equipped with a shovel and a net but neither will produce a treasure when I decode the map at that spot. I’ve tried decoding on all the tiles surrounded it as well.

    Cyber Helix

    Treasure maps always lead to buried treasure that has to be dug up. However, simply using the usual “Dig” action with a shovel will not reveal the treasure. To get the treasure out of the ground, you have to use the “Gather Treasure” action the shovel has. You’re doing that, right?


    Here is a fun one:
    Drag an equipped item over an item in the hotbar/quickslot, and it will equip the item that was in the quickslot even if it makes no sense, such equipping a bone to your legs.

    Also, if you have a legendary torch that decays, you get legendry ash.

    • This reply was modified 9 years, 6 months ago by A_Borealis.

    Found another one with my game-breaking powers:
    If you drop/throw an item with 0 decay remaining, the decay resets, essentially giving infinite decay time.
    This works with torches too. If they are dropped, the go out, but if they are thrown, they stay burning.


    1.9.2 glitch.
    When using Animal Fat as a fuel to light a fire, the fire is made but the Animal Fat is not consumed. It doesn’t even take durability damage if you succeed.

    I made sure Animal Fat was the only fuel-like item in my inventory.


    1.9.2 glitch (download version)

    using the preserve option with slime gel doesn’t function.


    1.9.2 bug
    I noticed when you repair an item it can gain a status (shown by a red aura around the item picture), and I really enjoyed this idea. This can easily be nullified by moving the item into a backpack and then removing it though.




    @Malvandra I could not reproduce your Animal Fat glitch. Were you trying to light a tree or other flammable tile on fire? Flammable tiles do not need a fuel-like item when trying to start them on fire.


    1.9.2 bug: when using zoom out from options, right clicks are broken afterwards. They are reporting sand instead of seaweed etc. Couldn’t figure out the offset or the factor how much it is off by though.

    I was playing from firefox/windows XP.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.