Non-stop duplication bug

Home Forums Wayward Non-stop duplication bug

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #4767

    I found a major bug that causes my items to duplicate and there’s no way I can find to stop it. I’m not exactly sure how I caused it, since I tried duplicate the bug in an older saved file of my game, and my items didn’t duplicate.
    I’ll just tell the events that has happened that may have caused this bug. First, I was going out to swim in the ocean, and then I fought a shark. I got some offal, but I didn’t do anything with the offal. A lot of turns later, I was still in the ocean and never got out. I received a message saying that the offal decayed, and then I threw it in the ocean. I’ve been just skipping turns in the ocean to replenish stamina, but while doing that after I threw the rotten meat, I noticed my weight was increasing. For some reason, I thought this was just a new feature of staying in the ocean causes your clothes to get wet and make it weigh more. I found a place I can stand on in the middle of the ocean, and skipped turns and I noticed my weight was still increasing. I then guessed it was a bug and it would get fixed if I reload the game.
    When I reloaded the game, I saw that my inventory was full of rotten meat, and it was duplicating every turn. I tried to throw them away, but my weight didn’t decrease because I was still gaining an invisible rotten meat in my inventory.
    I threw away all my inventory out in the ocean, but it didn’t really help.

    I used the Better Save/Load mod by Grom PE to saved my file, I’ll attach the saved file with this bug below.

    Forgot to mention that I’m playing this from the browser, which is verion 1.8 according to the title.


    My saved file link didn’t appear, I’ll just paste it here again.

    By the way, I found another bug on this site, using the link button causes links to not appear, but I can still see the link in the source code of the page.

    Also, I didn’t realize there was an edit button before I double posted and I don’t see a delete button, so I can’t just edit my first post and delete this.

    Just realized there are 2 versions up on the browser. I’m playing on 1.8 (not 1.8.6), so if this was fixed in a later version of the game, then you can ignore these posts.


    Thank you! We’ve been looking on a lead for this bug for awhile. I’ll try out the saves in a bit.


    I actually found out what caused the bug, in one of my bag, I had a cooked fishsteak at a decay of 0. Every turn, it was spawning a rotten meat, but it wasn’t deleting itself. After I took it out of my bag, it said it had around 4800 decay and then the duplication stopped.


    Got it! Glad you were able to make a save so I could re-produce it finally! This will be fixed in the upcoming beta 1.9.

    “Fixed a long standing obscure bug where if an item decayed in an inventory container and possibly envitem/tileitem that was at the 0 spot in the array (first spot in inventory), it would not remove it as the if check would bypass 0.”


    Hi, just wanted to point out to anyone experiencing this bug still: Just go through your inventory and drop whatever is at decay: 0.

    I thought I might have to modify an external save, but realized I did not after reading here. Just wanted to make it a bit more clear because panic set in when I was dropping seemingly infinite rotting meat and was afraid the solution might not be simple.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.